ubox: upgrade to latest version
[openwrt.git] / tools / m4 / Makefile
index b760e15..080eb5d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,15 +14,13 @@ PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
 PKG_CAT:=zcat
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
 
-define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
-endef
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall