ramips: rename status led to wifi on WHR-300HP2, WHR-1166D, WHR-600D
[openwrt.git] / tools / libtool / Makefile
index 82730df..9fab8d9 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,10 +13,17 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
+HOST_CONFIGURE_VARS += \
+       lt_cv_sys_dlsearch_path=""
+
+define Host/Prepare
+       $(call Host/Prepare/Default)
+       (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
+       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap)
 endef
 
 define Host/Install