firmware-utils/mkfwimage2: allow to use numbers in partition names
[openwrt.git] / tools / ccache / Makefile
index 8848fa5..9020c9c 100644 (file)
@@ -13,20 +13,18 @@ PKG_VERSION:=3.1.7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
 PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
+
 define Host/Install/ccache
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
        $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
 endef
 
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Compile
-       $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
-  endef
-
   define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)