tools/mtd-utils: prefer static linking
[openwrt.git] / tools / automake / Makefile
index 300bee2..0eea101 100644 (file)
@@ -15,8 +15,18 @@ PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
-HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+HOST_CONFIGURE_ARGS += \
+       --datarootdir=$(STAGING_DIR_HOST)/share \
+       --disable-silent-rules
+
+HOST_CONFIGURE_VARS += \
+       PERL="/usr/bin/env perl" \
+       am_cv_prog_PERL_ithreads=no
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+       $(call Host/Configure/Default)
+endef
 
 define Host/Install
        # remove old automake resources to avoid version conflicts