[toolchain/uClibc] backport upstream fix for dst computation
[openwrt.git] / toolchain / glibc / Makefile
index 73dbdd8..caf4b08 100644 (file)
@@ -9,30 +9,19 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=glibc
 PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
 
-ifeq ($(PKG_VERSION),2.3.6)
-  PKG_MD5SUM:=bfdce99f82d6dbcb64b7f11c05d6bc96
-endif
-ifeq ($(PKG_VERSION),2.6.1)
-  PKG_MD5SUM:=11cf6d3fc86dbe0890b8d00372eb6286
-endif
-ifeq ($(PKG_VERSION),2.7)
-  PKG_MD5SUM:=065c5952b439deba40083ccd67bcc8f7
+ifeq ($(PKG_VERSION),2.14)
+  PKG_MD5SUM:=1588cc22e796c296223744895ebc4cef
 endif
 
-PKG_SOURCE_URL:=@GNU/glibc/
+PKG_SOURCE_URL:=@GNU/glibc
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
-STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
-BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
-
-override CONFIG_AUTOREBUILD=
+include $(INCLUDE_DIR)/toolchain-build.mk
 
-include $(INCLUDE_DIR)/host-build.mk
-
-STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc_built
-STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc_installed
+HOST_STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc_built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc_installed
 
 HOST_BUILD_DIR1:=$(HOST_BUILD_DIR)-initial
 HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
@@ -57,11 +46,13 @@ GLIBC_CONFIGURE:= \
        libc_cv_forced_unwind=yes \
        libc_cv_c_cleanup=yes \
        libc_cv_386_tls=yes \
+       libc_cv_slibdir="/lib" \
        $(HOST_BUILD_DIR)/configure \
-               --prefix=/usr \
+               --prefix= \
                --build=$(GNU_HOST_NAME) \
                --host=$(REAL_GNU_TARGET_NAME) \
-               --with-headers="$(TOOLCHAIN_DIR)/usr/include" \
+               --with-headers="$(TOOLCHAIN_DIR)/include" \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el), --enable-kernel="2.6.0") \
                --disable-debug \
                --disable-profile \
                --enable-add-ons="$(GLIBC_ADD_ONS)" \
@@ -87,12 +78,11 @@ GLIBC_CONFIGURE_STAGE2:= \
 GLIBC_MAKE:= \
        $(MAKE) \
 
-
 define Host/SetToolchainInfo
        $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
-       $(SED) 's,^\(LIBC_PATCHVER\)=.*,\1=,' $(TOOLCHAIN_DIR)/info.mk
+       $(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
 endef
 
 define Stage1/Configure
@@ -111,11 +101,11 @@ define Stage1/Install
                cross-compiling=yes \
                install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
                install-headers
-       [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/bits/stdio_lim.h ] || \
+       [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/bits/stdio_lim.h ] || \
                $(CP) $(HOST_BUILD_DIR1)/bits/stdio_lim.h \
-                       $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/bits/stdio_lim.h
-       [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/gnu/stubs.h ] || \
-               touch $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/usr/include/gnu/stubs.h
+                       $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/bits/stdio_lim.h
+       [ -f $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/gnu/stubs.h ] || \
+               touch $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/include/gnu/stubs.h
 endef
 
 define Stage2/Configure