musl: update to latest git to fix MIPS and PowerPC TLS issues
[openwrt.git] / toolchain / gcc / common.mk
index 4ee344f..d07f607 100644 (file)
@@ -42,11 +42,11 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_COMP:=xz
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.9-linaro")
-      LINARO_RELEASE:=14.09
-      PKG_REV:=4.9-2014.09
-      PKG_VERSION:=4.9.2
+      LINARO_RELEASE:=15.03
+      PKG_REV:=4.9-2015.03
+      PKG_VERSION:=4.9.3
       PKG_VERSION_MAJOR:=4.9
-      PKG_MD5SUM:=ac920b5800623ff99137d3cf23ad09ca
+      PKG_MD5SUM:=f9d256d120adfbb45dd3e2d22b70cba9
       PKG_COMP:=xz
     endif
     ifneq ($(LINARO_RELEASE),)
@@ -61,9 +61,6 @@ else
   PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-  ifeq ($(PKG_VERSION),4.4.7)
-    PKG_MD5SUM:=295709feb4441b04e87dea3f1bab4281
-  endif
   ifeq ($(PKG_VERSION),4.6.3)
     PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
   endif
@@ -133,16 +130,12 @@ GCC_CONFIGURE:= \
                        --with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
+               --with-mpc=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float
 ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif
 
-ifeq ($(CONFIG_GCC_VERSION_4_4),)
-  GCC_CONFIGURE+= \
-               --with-mpc=$(TOPDIR)/staging_dir/host
-endif
-
 ifneq ($(CONFIG_SSP_SUPPORT),)
   GCC_CONFIGURE+= \
                --enable-libssp