rootfs_split: fix a typo, and fix compiler warnings
[openwrt.git] / target / linux / sibyte-2.6 / Makefile
index 3309a84..35cdb37 100644 (file)
@@ -1,19 +1,21 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.7
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=9682b2bd6e02f3087982d7c3f5ba824e
+ARCH:=mips
+BOARD:=sibyte
+BOARDNAME:=SiByte MIPS
+FEATURES:=broken
 
-include ../rules.mk
-include ./config
+LINUX_VERSION:=2.6.21.5
 
-include ../generic-$(KERNEL)/modules.mk
-include ../kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
 
+# include the profiles
+-include profiles/*.mk
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
-
+$(eval $(call BuildKernel))