ramips: switch to 3.3.2
[openwrt.git] / target / linux / s3c24xx / Makefile
index 309c176..57f6aa3 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,15 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=s3c24xx
-BOARDNAME:=s3c24xx
+BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
+CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -fno-caller-saves
+SUBTARGETS:=openmoko-gta02
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.30.10
 
 DEVICE_TYPE=phone
 
 define Target/Description
-       OpenMoko gta02
+       S3C24xx arm
 endef
 
 include $(INCLUDE_DIR)/target.mk