[adm5120] cosmetic changes in flash driver
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index 306734b..d52974f 100644 (file)
@@ -9,15 +9,25 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=broken jffs2
+FEATURES:=squashfs jffs2 pci broken
+
+LINUX_VERSION:=2.6.21.5
 
 define Target/Description
         Build firmware images for RDC3211 based routers
-        (e.g. Airlink101 AR525W)
+        (e.g. Airlink101 AR525W, Linksys WRT54R)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+    define Kernel/SetInitramfs
+       rm -f $(BUILD_DIR)/root/sbin/init
+       ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
+       $(CP) $(PLATFORM_DIR)/image/preinit.arch $(BUILD_DIR)/root/etc/
+    endef
+endif
+
 # include the profiles
 -include profiles/*.mk