ramips: disable hg255d
[openwrt.git] / target / linux / ramips / modules.mk
index 0d29332..1c84598 100644 (file)
@@ -5,22 +5,17 @@
 # See /LICENSE for more information.
 #
 
-define KernelPackage/usb-rt305x-dwc_otg
-  TITLE:=RT305X USB controller driver
-  DEPENDS:=@TARGET_ramips_rt305x
-  KCONFIG:= \
-       CONFIG_DWC_OTG \
-       CONFIG_DWC_OTG_HOST_ONLY=y \
-       CONFIG_DWC_OTG_DEVICE_ONLY=n \
-       CONFIG_DWC_OTG_DEBUG=n
-  FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
-  AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
-  $(call AddDepends/usb)
+I2C_RALINK_MODULES:= \
+  CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink
+
+define KernelPackage/i2c-ralink
+  $(call i2c_defaults,$(I2C_RALINK_MODULES),59)
+  TITLE:=Ralink I2C Controller
+  DEPENDS:=@TARGET_ramips kmod-i2c-core
 endef
 
-define KernelPackage/usb-rt305x-dwc_otg/description
-  This driver provides USB Device Controller support for the
-  Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+define KernelPackage/i2c-ralink/description
+ Kernel modules for enable ralink i2c controller.
 endef
 
-$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
+$(eval $(call KernelPackage,i2c-ralink))