ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-whr-g300n.c
index 4e0e810..6313135 100644 (file)
@@ -63,7 +63,7 @@ static struct mtd_partition whr_g300n_partitions[] = {
                .offset = 0x3f0000,
                .size   = 0x010000,
        }, {
-               .name   = "openwrt",
+               .name   = "firmware",
                .offset = 0x050000,
                .size   = 0x3a0000,
        }
@@ -97,14 +97,14 @@ static struct gpio_button whr_g300n_gpio_buttons[] __initdata = {
        {
                .desc           = "reset",
                .type           = EV_KEY,
-               .code           = BTN_0,
+               .code           = KEY_RESTART,
                .threshold      = 3,
                .gpio           = WHR_G300N_GPIO_BUTTON_RESET,
                .active_low     = 1,
        }, {
                .desc           = "aoss",
                .type           = EV_KEY,
-               .code           = BTN_1,
+               .code           = KEY_WPS_BUTTON,
                .threshold      = 3,
                .gpio           = WHR_G300N_GPIO_BUTTON_AOSS,
                .active_low     = 1,
@@ -137,6 +137,7 @@ static void __init whr_g300n_init(void)
                                     ARRAY_SIZE(whr_g300n_gpio_buttons),
                                     whr_g300n_gpio_buttons);
        rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
 MIPS_MACHINE(RAMIPS_MACH_WHR_G300N, "WHR-G300N", "Buffalo WHR-G300N",