ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-v22rw-2x2.c
index 812dfb4..382da75 100644 (file)
@@ -55,7 +55,7 @@ static struct mtd_partition v22rw_2x2_partitions[] = {
                .offset = 0x150000,
                .size   = 0x2b0000,
        }, {
-               .name   = "openwrt",
+               .name   = "firmware",
                .offset = 0x050000,
                .size   = 0x3b0000,
        }
@@ -85,14 +85,14 @@ static struct gpio_button v22rw_2x2_gpio_buttons[] __initdata = {
        {
                .desc           = "reset",
                .type           = EV_KEY,
-               .code           = BTN_0,
+               .code           = KEY_RESTART,
                .threshold      = 3,
                .gpio           = V22RW_2X2_GPIO_BUTTON_SWRST,
                .active_low     = 1,
        }, {
                .desc           = "wps",
                .type           = EV_KEY,
-               .code           = BTN_1,
+               .code           = KEY_WPS_BUTTON,
                .threshold      = 3,
                .gpio           = V22RW_2X2_GPIO_BUTTON_WPS,
                .active_low     = 1,
@@ -111,6 +111,7 @@ static void __init v22rw_2x2_init(void)
                                     ARRAY_SIZE(v22rw_2x2_gpio_buttons),
                                     v22rw_2x2_gpio_buttons);
        rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
 MIPS_MACHINE(RAMIPS_MACH_V22RW_2X2, "V22RW-2X2", "Ralink AP-RT3052-V22RW-2X2",