ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-v22rw-2x2.c
index 64466e2..382da75 100644 (file)
@@ -1,7 +1,7 @@
 /*
  *  Ralink AP-RT3052-V22RW-2X2 board support
  *
- *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2009-2010 Gabor Juhos <juhosg@openwrt.org>
  *
  *  This program is free software; you can redistribute it and/or modify it
  *  under the terms of the GNU General Public License version 2 as published
 #include <linux/mtd/mtd.h>
 #include <linux/mtd/partitions.h>
 #include <linux/mtd/physmap.h>
-#include <linux/leds.h>
 
-#include <asm/mips_machine.h>
 #include <asm/mach-ralink/machine.h>
-#include <asm/mach-ralink/dev_gpio_leds.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
 #include <asm/mach-ralink/rt305x.h>
 #include <asm/mach-ralink/rt305x_regs.h>
 
@@ -28,6 +27,8 @@
 #define V22RW_2X2_GPIO_LED_SECURITY    13
 #define V22RW_2X2_GPIO_LED_WPS         14
 
+#define V22RW_2X2_BUTTONS_POLL_INTERVAL        20
+
 #ifdef CONFIG_MTD_PARTITIONS
 static struct mtd_partition v22rw_2x2_partitions[] = {
        {
@@ -54,7 +55,7 @@ static struct mtd_partition v22rw_2x2_partitions[] = {
                .offset = 0x150000,
                .size   = 0x2b0000,
        }, {
-               .name   = "openwrt",
+               .name   = "firmware",
                .offset = 0x050000,
                .size   = 0x3b0000,
        }
@@ -80,6 +81,24 @@ static struct gpio_led v22rw_2x2_leds_gpio[] __initdata = {
        }
 };
 
+static struct gpio_button v22rw_2x2_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = V22RW_2X2_GPIO_BUTTON_SWRST,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = V22RW_2X2_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
 static void __init v22rw_2x2_init(void)
 {
        rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
@@ -88,7 +107,12 @@ static void __init v22rw_2x2_init(void)
        rt305x_register_ethernet();
        ramips_register_gpio_leds(-1, ARRAY_SIZE(v22rw_2x2_leds_gpio),
                                  v22rw_2x2_leds_gpio);
+       ramips_register_gpio_buttons(-1, V22RW_2X2_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(v22rw_2x2_gpio_buttons),
+                                    v22rw_2x2_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
-MIPS_MACHINE(RAMIPS_MACH_V22RW_2X2, "Ralink AP-RT3052-V22RW-2X2",
+MIPS_MACHINE(RAMIPS_MACH_V22RW_2X2, "V22RW-2X2", "Ralink AP-RT3052-V22RW-2X2",
             v22rw_2x2_init);