ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-fonera20n.c
index d3a68db..bbf152f 100644 (file)
@@ -2,6 +2,7 @@
  *  La Fonera20N board support
  *
  *  Copyright (C) 2009 John Crispin <blogic@openwrt.org>
+ *  Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
  *
  *  This program is free software; you can redistribute it and/or modify it
  *  under the terms of the GNU General Public License version 2 as published
@@ -13,9 +14,9 @@
 #include <linux/mtd/mtd.h>
 #include <linux/mtd/partitions.h>
 #include <linux/mtd/physmap.h>
-#include <linux/leds.h>
 
 #include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
 #include <asm/mach-ralink/dev-gpio-leds.h>
 #include <asm/mach-ralink/rt305x.h>
 #include <asm/mach-ralink/rt305x_regs.h>
@@ -28,6 +29,8 @@
 #define FONERA20N_GPIO_LED_POWER       9
 #define FONERA20N_GPIO_LED_USB         14
 
+#define FONERA20N_BUTTONS_POLL_INTERVAL        20
+
 #ifdef CONFIG_MTD_PARTITIONS
 static struct mtd_partition fonera20n_partitions[] = {
        {
@@ -54,7 +57,7 @@ static struct mtd_partition fonera20n_partitions[] = {
                .offset = 0x150000,
                .size   = 0x6b0000,
        }, {
-               .name   = "openwrt",
+               .name   = "firmware",
                .offset = 0x050000,
                .size   = 0x7b0000,
        }
@@ -84,6 +87,24 @@ static struct gpio_led fonera20n_leds_gpio[] __initdata = {
        }
 };
 
+static struct gpio_button fonera20n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = FONERA20N_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "switch",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .threshold      = 3,
+               .gpio           = FONERA20N_GPIO_SWITCH,
+               .active_low     = 1,
+       }
+};
+
 static void __init fonera20n_init(void)
 {
        rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
@@ -93,7 +114,13 @@ static void __init fonera20n_init(void)
        ramips_register_gpio_leds(-1, ARRAY_SIZE(fonera20n_leds_gpio),
                                  fonera20n_leds_gpio);
 
+       ramips_register_gpio_buttons(-1, FONERA20N_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(fonera20n_gpio_buttons),
+                                    fonera20n_gpio_buttons);
+
        rt305x_register_ethernet();
+       rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
 MIPS_MACHINE(RAMIPS_MACH_FONERA20N, "FONERA20N", "La Fonera 2.0N",