ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-f5d8235-v2.c
index 90c48ad..b406281 100644 (file)
@@ -14,7 +14,7 @@
 #include <linux/mtd/partitions.h>
 #include <linux/mtd/physmap.h>
 
-#include <linux/rtl8366rb.h>
+#include <linux/rtl8366.h>
 
 #include <asm/mach-ralink/machine.h>
 #include <asm/mach-ralink/dev-gpio-buttons.h>
@@ -109,7 +109,7 @@ static struct physmap_flash_data f5d8235v2_flash_data = {
 };
 
 
-static struct rtl8366rb_platform_data f5d8235v2_switch_data = {
+static struct rtl8366_platform_data f5d8235v2_switch_data = {
        .gpio_sda       = RT305X_GPIO_I2C_SD,
        .gpio_sck       = RT305X_GPIO_I2C_SCLK,
 };
@@ -135,6 +135,7 @@ static void __init f5d8235v2_init(void)
        rt305x_register_ethernet();
        platform_device_register(&f5d8235v2_switch);
        rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
 MIPS_MACHINE(RAMIPS_MACH_F5D8235_V2, "F5D8235_V2", "Belkin F5D8235 v2",