ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-dir-300-revb.c
index dd2a5f4..5a947e8 100644 (file)
@@ -51,15 +51,15 @@ static struct mtd_partition dir_300b_partitions[] = {
        }, {
                .name   = "kernel",
                .offset = 0x050000,
-               .size   = 0x090000,
+               .size   = 0x0d0000,
        }, {
                .name   = "rootfs",
-               .offset = 0x140000,
-               .size   = 0x2B0000,
+               .offset = 0x120000,
+               .size   = 0x2e0000,
        }, {
-               .name   = "openwrt",
+               .name   = "firmware",
                .offset = 0x050000,
-               .size   = 0x3a0000,
+               .size   = 0x3b0000,
        }
 };
 #endif /* CONFIG_MTD_PARTITIONS */
@@ -91,14 +91,14 @@ static struct gpio_button dir_300b_gpio_buttons[] __initdata = {
        {
                .desc           = "reset",
                .type           = EV_KEY,
-               .code           = BTN_0,
+               .code           = KEY_RESTART,
                .threshold      = 3,
                .gpio           = DIR_300B_GPIO_BUTTON_RESET,
                .active_low     = 1,
        }, {
                .desc           = "wps",
                .type           = EV_KEY,
-               .code           = BTN_1,
+               .code           = KEY_WPS_BUTTON,
                .threshold      = 3,
                .gpio           = DIR_300B_GPIO_BUTTON_WPS,
                .active_low     = 1,
@@ -116,6 +116,8 @@ static void __init dir_300b_init(void)
        ramips_register_gpio_buttons(-1, DIR_300B_BUTTONS_POLL_INTERVAL,
                                     ARRAY_SIZE(dir_300b_gpio_buttons),
                                     dir_300b_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
 MIPS_MACHINE(RAMIPS_MACH_DIR_300_REVB, "DIR-300-revB", "D-Link DIR-300 revB",