ramips: rt305x: sort Kconfig/Makefile entries
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / mach-dir-300-revb.c
index 86152b9..5a947e8 100644 (file)
@@ -1,7 +1,7 @@
 /*
  *  D-Link DIR-300 rev B board support
  *
- *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2009-2010 Gabor Juhos <juhosg@openwrt.org>
  *
  *  This program is free software; you can redistribute it and/or modify it
  *  under the terms of the GNU General Public License version 2 as published
 #include <linux/mtd/mtd.h>
 #include <linux/mtd/partitions.h>
 #include <linux/mtd/physmap.h>
-#include <linux/leds.h>
 
-#include <asm/mips_machine.h>
 #include <asm/mach-ralink/machine.h>
-#include <asm/mach-ralink/dev_gpio_leds.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
 #include <asm/mach-ralink/rt305x.h>
 #include <asm/mach-ralink/rt305x_regs.h>
 
@@ -30,6 +29,8 @@
 #define DIR_300B_GPIO_BUTTON_WPS       0       /* active low */
 #define DIR_300B_GPIO_BUTTON_RESET     10      /* active low */
 
+#define DIR_300B_BUTTONS_POLL_INTERVAL 20
+
 #ifdef CONFIG_MTD_PARTITIONS
 static struct mtd_partition dir_300b_partitions[] = {
        {
@@ -50,15 +51,15 @@ static struct mtd_partition dir_300b_partitions[] = {
        }, {
                .name   = "kernel",
                .offset = 0x050000,
-               .size   = 0x090000,
+               .size   = 0x0d0000,
        }, {
                .name   = "rootfs",
-               .offset = 0x140000,
-               .size   = 0x2B0000,
+               .offset = 0x120000,
+               .size   = 0x2e0000,
        }, {
-               .name   = "openwrt",
+               .name   = "firmware",
                .offset = 0x050000,
-               .size   = 0x3a0000,
+               .size   = 0x3b0000,
        }
 };
 #endif /* CONFIG_MTD_PARTITIONS */
@@ -86,6 +87,24 @@ static struct gpio_led dir_300b_leds_gpio[] __initdata = {
        }
 };
 
+static struct gpio_button dir_300b_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = DIR_300B_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = DIR_300B_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
 static void __init dir_300b_init(void)
 {
        rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
@@ -94,6 +113,12 @@ static void __init dir_300b_init(void)
        rt305x_register_ethernet();
        ramips_register_gpio_leds(-1, ARRAY_SIZE(dir_300b_leds_gpio),
                                  dir_300b_leds_gpio);
+       ramips_register_gpio_buttons(-1, DIR_300B_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(dir_300b_gpio_buttons),
+                                    dir_300b_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
 }
 
-MIPS_MACHINE(RAMIPS_MACH_DIR_300_REVB, "D-Link DIR-300 revB", dir_300b_init);
+MIPS_MACHINE(RAMIPS_MACH_DIR_300_REVB, "DIR-300-revB", "D-Link DIR-300 revB",
+            dir_300b_init);