mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after...
[openwrt.git] / target / linux / ramips / Makefile
index 325a41c..ba00c92 100644 (file)
@@ -10,10 +10,10 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.6.7
+LINUX_VERSION:=3.6.11
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\