blacklist alsa driver for ar7
[openwrt.git] / target / linux / package / Makefile
index 84402cc..7e8588d 100644 (file)
@@ -1,29 +1,30 @@
 # Main makefile for the packages
 include $(TOPDIR)/rules.mk
 
+ifneq ($(BOARD),ar7)
+package-$(BR2_PACKAGE_KMOD_ALSA) += alsa
+endif
 package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
 package-$(BR2_PACKAGE_KMOD_MINI_FO) += mini_fo
 package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
 package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
+package-$(BR2_PACKAGE_KMOD_MADWIFI) += madwifi
 package-y += openwrt
 
-ifeq ($(BOARD),brcm)
-package-$(BR2_PACKAGE_WIFICONF) += wificonf
-package-y += nvram
-
-ifeq ($(LINUX_VERSION),2.4.30)
+ifeq ($(BOARD)-$(KERNEL),brcm-2.4)
 package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
-endif
-
-nvram-compile: openwrt-compile
+package-$(BR2_PACKAGE_KMOD_DIAG) += diag
+wlcompat-compile: openwrt-compile
 endif
 
 all: compile install
 clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
+prepare: $(patsubst %,%-prepare,$(package-y) $(package-m))
 compile: $(patsubst %,%-compile,$(package-y) $(package-m))
 install: $(patsubst %,%-install,$(package-y))
 
 MAKEOPTS:=     BOARD="$(BOARD)" \
+               KERNEL="$(KERNEL)" \
                IPKG="$(IPKG)" \
                TARGET_DIR="$(TARGET_DIR)" \
                BUILD_DIR="$(BUILD_DIR)" \