all targets: remove all =m kernel config symbols
[openwrt.git] / target / linux / omap24xx / Makefile
index b36fcc4..af82384 100644 (file)
@@ -8,17 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap24xx
-BOARDNAME:=TI OMAP-24xx
+BOARDNAME:=TI OMAP24xx
 MAINTAINER:=Michael Buesch <m@bues.ch>
-FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio broken
+FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
+CPU_TYPE:=arm1136j-s
 
-LINUX_VERSION:=3.3.7
+KERNEL_PATCHVER:=3.3
 
 define Target/Description
        TI OMAP-24xx
 endef
 
-CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk