ar71xx: Arduino Yun board 'WLAN RST' button support
[openwrt.git] / target / linux / mpc85xx / Makefile
index e43327a..a32be90 100644 (file)
@@ -14,12 +14,15 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-KERNEL_PATCHVER:=3.18
-
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio kmod-booke-wdt \