mpc85xx: use wpad-mini in WDR4900 profile instead of wpad
[15.05/openwrt.git] / target / linux / mpc85xx / Makefile
index 19dff42..3766968 100644 (file)
@@ -9,18 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+CPU_TYPE:=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.8.2
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio kmod-booke-wdt \
-       swconfig
+       swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.