ar71xx: add missing tx gain table flag for buffalo wzr-hp-g450h
[openwrt.git] / target / linux / mpc52xx / image / Makefile
index 177ca07..fc7e9cd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,12 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
-endef
-
 define Image/BuildKernel
-       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+       cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
 endef
 
 define Image/Build/ext2
-       cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+       cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
 endef
 
 define Image/Build