kernel: makefiles: make use of new var KERNEL_PATCHVER
[15.05/openwrt.git] / target / linux / mpc52xx / Makefile
index ff91d60..aa3c5a7 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+CPU_TYPE:=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.3.2
+KERNEL_PATCHVER:=3.8
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,4 +20,6 @@ define Target/Description
        Build images for the Freescale MPC52xx based boards.
 endef
 
+KERNELNAME:=zImage
+
 $(eval $(call BuildTarget))