kernel: do not build FW_LOADER as a module.
[openwrt.git] / target / linux / mpc52xx / Makefile
index 6d69e99..7b07058 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+CFLAGS:=-Os -pipe -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,4 +20,6 @@ define Target/Description
        Build images for the Freescale MPC52xx based boards.
 endef
 
+KERNELNAME:="zImage"
+
 $(eval $(call BuildTarget))