[mcs814x] nuport-mac: rework PHY interrupt configuration to avoid races
[openwrt.git] / target / linux / mcs814x / Makefile
index 018cdb0..a581849 100644 (file)
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mcs814x
 BOARDNAME:=Moschip MCS814x
-FEATURES:=pci usb
+FEATURES:=pci usb squashfs jffs2
 CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
 
+DEVICE_TYPE:=other
+
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
@@ -22,7 +24,7 @@ DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
                  kmod-usb-storage kmod-fs-vfat \
                  kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
                  kmod-nls-utf8 \
-                 kmod-mcs814x-wdt
+                 kmod-mcs814x-wdt kmod-ledtrig-usbdev
 
 KERNELNAME:="zImage dtbs"