ar71xx: add kernel support for the TP-LINK Archer C7 board
[openwrt.git] / target / linux / mcs814x / Makefile
index a62b6e5..47569fe 100644 (file)
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mcs814x
 BOARDNAME:=Moschip MCS814x
-FEATURES:=pci usb
+FEATURES:=usb squashfs jffs2
 CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
 
+DEVICE_TYPE:=other
+
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \