prepare for the transition to linux 2.6.22 - make it possible to override the kernel...
[openwrt.git] / target / linux / ixp4xx-2.6 / Makefile
index 86df91f..d896334 100644 (file)
@@ -6,18 +6,17 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
+ARCH:=armeb
 BOARD:=ixp4xx
 BOARDNAME:=Intel XScale IXP4xx
-FEATURES:=pci usb jffs2
+FEATURES:=squashfs
 
 define Target/Description
 endef
 
+include $(INCLUDE_DIR)/kernel-build.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+# include the profiles
+-include profiles/*.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))