ar71xx: add a helper function to set RXDV/RXD of ETH_CFG on AR934x
[openwrt.git] / target / linux / ipq806x / Makefile
index 7521e97..1512b30 100644 (file)
@@ -7,11 +7,16 @@ BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
 FEATURES:=squashfs
 CPU_TYPE:=cortex-a7
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.12
+KERNEL_PATCHVER:=3.18
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug kmod-qca-nss-gmac swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
+
 
 $(eval $(call BuildTarget))