generic: fix build failure in MIPS kexec code if SMP is enabled
[openwrt.git] / target / linux / generic / patches-3.3 / 725-phy_rtl8306.patch
index 42cd274..db0ee65 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -120,6 +120,10 @@ config AR8216_PHY
-       tristate "Driver for Atheros AR8216 switches"
+@@ -126,6 +126,10 @@ config AR8216_PHY
+       select ETHERNET_PACKET_MANGLE
        select SWCONFIG
  
 +config RTL8306_PHY
@@ -13,7 +13,7 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
+@@ -21,6 +21,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
  obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o