kernel/3.3: remove yaffs support
[openwrt.git] / target / linux / generic / patches-3.3 / 270-regmap_dynamic.patch
index a583cb4..b1cfc8a 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-3.3.8/drivers/base/regmap/Kconfig
-===================================================================
---- linux-3.3.8.orig/drivers/base/regmap/Kconfig       2013-01-04 23:40:36.288481779 +0100
-+++ linux-3.3.8/drivers/base/regmap/Kconfig    2013-01-04 23:40:39.760481927 +0100
-@@ -3,16 +3,17 @@
+--- a/drivers/base/regmap/Kconfig
++++ b/drivers/base/regmap/Kconfig
+@@ -3,16 +3,18 @@
  # subsystems should select the appropriate symbols.
  
  config REGMAP
@@ -20,23 +18,38 @@ Index: linux-3.3.8/drivers/base/regmap/Kconfig
  config REGMAP_SPI
 -      tristate
 +      select REGMAP
++      depends on SPI_MASTER
 +      tristate "Regmap SPI"
  
  config REGMAP_IRQ
        bool
-Index: linux-3.3.8/drivers/base/regmap/Makefile
-===================================================================
---- linux-3.3.8.orig/drivers/base/regmap/Makefile      2012-06-01 09:16:13.000000000 +0200
-+++ linux-3.3.8/drivers/base/regmap/Makefile   2013-01-05 00:20:31.236584162 +0100
+--- a/drivers/base/regmap/Makefile
++++ b/drivers/base/regmap/Makefile
 @@ -1,6 +1,8 @@
 -obj-$(CONFIG_REGMAP) += regmap.o regcache.o
 -obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o
 -obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
 +regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o
-+ifdef CONFIG_DEBUGFS
++ifdef CONFIG_DEBUG_FS
 +regmap-core-objs += regmap-debugfs.o
 +endif
 +obj-$(CONFIG_REGMAP) += regmap-core.o
  obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
  obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
  obj-$(CONFIG_REGMAP_IRQ) += regmap-irq.o
+--- a/drivers/base/regmap/regmap.c
++++ b/drivers/base/regmap/regmap.c
+@@ -13,6 +13,7 @@
+ #include <linux/slab.h>
+ #include <linux/module.h>
+ #include <linux/mutex.h>
++#include <linux/module.h>
+ #include <linux/err.h>
+ #define CREATE_TRACE_POINTS
+@@ -679,3 +680,5 @@ static int __init regmap_initcall(void)
+       return 0;
+ }
+ postcore_initcall(regmap_initcall);
++
++MODULE_LICENSE("GPL");