ar71xx: add kernel support for the TEW-732BR board
[openwrt.git] / target / linux / cns3xxx / Makefile
index c944d1c..a169d0b 100644 (file)
@@ -10,10 +10,10 @@ ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.6
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -22,7 +22,7 @@ define Target/Description
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="uImage"
+KERNELNAME:="zImage uImage"
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini