bcm63xx: split into two subtargets, generic and SMP
[openwrt.git] / target / linux / brcm63xx / Makefile
index 4a3b43a..529cbeb 100644 (file)
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
+SUBTARGETS:=generic smp
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=3.8.11
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers