brcm47xx: fix parts of the cache code that were not covered by the kmap_coherent...
[openwrt.git] / target / linux / brcm47xx-2.6 / Makefile
index ab79d82..34c29cf 100644 (file)
@@ -8,16 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx (new code)
-FEATURES:=squashfs broken
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs usb
+
+LINUX_VERSION:=2.6.22-rc5
+LINUX_KERNEL_MD5SUM:=50dda556ae492f68ff7c273e1f357c55
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
-# DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
 # include the profiles
 -include profiles/*.mk