ramips: fix ethernet stability issue introduced by recent kernel upgrade
[openwrt.git] / target / linux / brcm47xx / profiles / 101-Broadcom-wl.mk
index 1464b7e..e06ceb0 100644 (file)
@@ -1,19 +1,19 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Broadcom-wl
-  NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+  NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+  PACKAGES:=-wpad-mini kmod-b44 kmod-tg3 kmod-bgmac kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
-       Package set compatible with hardware using Broadcom BCM43xx cards
-       using the proprietary broadcom wireless "wl" driver and b44 Ethernet
-       driver.
+       Package set compatible with hardware any Broadcom BCM47xx or BCM535x 
+       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom 
+       wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
 endef
 
 $(eval $(call Profile,Broadcom-wl))