brcm47xx: improve suppressing printing if a module was found in preinit function.
[openwrt.git] / target / linux / brcm47xx / modules.mk
index a7e25fd..abc2c9c 100644 (file)
@@ -20,3 +20,19 @@ define KernelPackage/usb-brcm47xx
 endef
 
 $(eval $(call KernelPackage,usb-brcm47xx))
+
+
+define KernelPackage/ocf-ubsec-ssb
+  TITLE:=BCM5365P IPSec Core driver
+  DEPENDS:=@TARGET_brcm47xx +kmod-crypto-ocf
+  KCONFIG:=CONFIG_OCF_UBSEC_SSB
+  FILES:=$(LINUX_DIR)/crypto/ocf/ubsec_ssb/ubsec_ssb.ko
+  AUTOLOAD:=$(call AutoLoad,10,ubsec_ssb)
+  $(call AddDepends/crypto)
+endef
+
+define KernelPackage/ocf-ubsec-ssb/description
+  This package contains the OCF driver for the BCM5365p IPSec Core
+endef
+
+$(eval $(call KernelPackage,ocf-ubsec-ssb))