brcm47xx: fix detection of some Linksys WRT54G* devices
[openwrt.git] / target / linux / brcm47xx / Makefile
index 5804ee9..ab0dc7b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs usb
+FEATURES:=squashfs usb pcmcia
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=3.10.32
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))