kernel: refresh patches on linux 3.18
[openwrt.git] / target / linux / brcm2708 / Makefile
index f8cd6c8..30f6e1d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,23 @@ include $(INCLUDE_DIR)/host.mk
 
 ARCH:=arm
 BOARD:=brcm2708
-BOARDNAME:=Broadcom BCM2708/BCM2835
+BOARDNAME:=Broadcom BCM2708/BCM2709
 FEATURES:=ext4 audio usb usbgadget display gpio
-MAINTAINER:=Ian Ridge <ianridge[at]gmail.com>
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+CPU_TYPE:=arm1176jzf-s
+CPU_SUBTYPE:=vfp
+SUBTARGETS:=bcm2708 bcm2709
 
-LINUX_VERSION:=3.10
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
 
 define Target/Description
-       Build firmware image for Broadcom BCM2708/BCM2835 SoC devices.
+       Build firmware image for Broadcom BCM2708/BCM2709 SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef
 
-CFLAGS:=-pipe -march=armv6 -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=softfp -marm
+KERNELNAME:=Image
 
 $(eval $(call BuildTarget))