targets: remove useless quotes around KERNELNAME
[openwrt.git] / target / linux / bcm53xx / Makefile
index d41bf53..69f30f8 100644 (file)
@@ -9,9 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs usb pci pcie gpio
+FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
 
 LINUX_VERSION:=3.14.18
 
@@ -21,8 +22,10 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))