Finally fix the pesky x86-2.6 block2mtd related crash (#1058)
[openwrt.git] / target / linux / au1000-2.6 / Makefile
index ca85b73..25fc776 100644 (file)
@@ -6,21 +6,42 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mipsel
+BOARD:=au1000
+BOARDNAME:=AMD Alchemy AU1x00
+FEATURES:=jffs2
 
-include ./config
-include $(INCLUDE_DIR)/kernel-build.mk
+define Target/Description
+       Build firmware for AMD Alchemy 1500 boards
+       (e.g. 4G-Systems Mesh/Access Cube ...)
+endef
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += yamonenv
 
-$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/vmlinux
+define Kernel/BuildImage
+       $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
+endef
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/Intel
+  NAME:=Intel IPW2200 WiFi
+  PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
+define Profile/Broadcom
+  NAME:=Broadcom BCM43xx WiFi
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
+$(eval $(call BuildKernel))
 
-compile: $(LINUX_BUILD_DIR)/zImage.flash.srec