move target/image/platform to target/linux/platform/image
[openwrt.git] / target / linux / au1000-2.6 / Makefile
index 8c1c67d..258990f 100644 (file)
@@ -1,25 +1,32 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=cb675279c9711237a06ebb8379a4da27
+ARCH:=mipsel
+BOARD:=au1000
+BOARDNAME:=AMD Alchemy AU1x00
+FEATURES:=jffs2
 
-include ../rules.mk
-include ./config
+define Target/Description
+       Build firmware for AMD Alchemy 1500 boards
+       (e.g. 4G-Systems Mesh/Access Cube ...)
+endef
 
-include ../generic-$(KERNEL)/modules.mk
-include ../kernel.mk
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
+include $(INCLUDE_DIR)/kernel-build.mk
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+define Kernel/BuildImage
+       $(call Kernel/BuildImage/Default)
+       $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
+       $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
+endef
 
-$(LINUX_BUILD_DIR)/bzImage: $(LINUX_DIR)/vmlinux
-       $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) bzImage
-       $(CP) $(LINUX_DIR)/vmlinux $@
-       touch $@
+$(eval $(call BuildKernel))
 
-compile: $(LINUX_DIR)/vmlinux