[generic/3.12]: refresh patch
[openwrt.git] / target / linux / atheros / Makefile
index 611345f..3f4bcd0 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=atheros
-BOARDNAME:=Atheros
-FEATURES:=squashfs jffs2
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs
+
+LINUX_VERSION:=3.8.13
+
+include $(INCLUDE_DIR)/target.mk
 
-LINUX_VERSION:=2.6.22.4
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-madwifi
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))