imx6: add pfuze100 regulator support
[openwrt.git] / target / linux / at91 / modules.mk
index 9c8ef3d..4678b92 100644 (file)
@@ -38,10 +38,10 @@ $(eval $(call KernelPackage,pwm-atmel))
 define KernelPackage/at91-adc
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ADC on atmel SoC
-  DEPENDS:=@TARGET_at91
+  DEPENDS:=@TARGET_at91 +kmod-iio-core
   KCONFIG:=CONFIG_AT91_ADC
-  FILES:=$(LINUX_DIR)/drivers/misc/at91-adc.ko
-  AUTOLOAD:=$(call AutoLoad,40,at91-adc)
+  FILES:=$(LINUX_DIR)/drivers/iio/adc/at91_adc.ko
+  AUTOLOAD:=$(call AutoLoad,40,at91_adc)
 endef
 
 define KernelPackage/at91-adc/description
@@ -49,3 +49,20 @@ define KernelPackage/at91-adc/description
 endef
 
 $(eval $(call KernelPackage,at91-adc))
+
+
+I2C_AT91_MODULES:=\
+  CONFIG_I2C_AT91:drivers/i2c/busses/i2c-at91
+
+define KernelPackage/at91-i2c
+  $(call i2c_defaults,$(I2C_AT91_MODULES),55)
+  TITLE:=I2C (TWI) master driver for Atmel AT91
+  DEPENDS:=@TARGET_at91 +kmod-i2c-core
+endef
+
+define KernelPackage/at91-i2c/description
+ Kernel module to use the I2C (TWI) master driver for Atmel AT91
+endef
+
+$(eval $(call KernelPackage,at91-i2c))
+