make the uml kernel config compatible with both 32 bit and 64 bit systems
[openwrt.git] / target / linux / aruba-2.6 / Makefile
index 652e4b9..5d3e19e 100644 (file)
@@ -1,16 +1,21 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mips
+BOARD:=aruba
+BOARDNAME:=Aruba
+FEATURES:=jffs2
 
-include ./config
-include $(TOPDIR)/include/kernel.mk
-include $(TOPDIR)/include/kernel-build.mk
+define Target/Description
+       Build firmware images for Aruba boards
+endef
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-madwifi
 
+$(eval $(call BuildKernel))