[ar71xx]: add support for the archer c5
[openwrt.git] / target / linux / ar71xx / generic / profiles / d-link.mk
index dbb2c6a..eb721c3 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/DIR505A1
        NAME:=D-Link DIR-505 rev. A1
-       PACKAGES:=
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/DIR505A1/Description
@@ -60,6 +60,16 @@ endef
 
 $(eval $(call Profile,DIR615C1))
 
+define Profile/DIR615E1
+       NAME:=D-Link DIR-615 rev. E1
+       PACKAGES:=
+endef
+
+define Profile/DIR615E1/Description
+       Package set optimized for the D-Link DIR-615 rev. E1.
+endef
+
+$(eval $(call Profile,DIR615E1))
 
 define Profile/DIR615E4
        NAME:=D-Link DIR-615 rev. E4