clean up filesystem selction
[openwrt.git] / target / Makefile
index 836469d..195878e 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
@@ -14,7 +20,7 @@ linux-install: $(BIN_DIR)
 sdk-compile: linux-install
 image_install: linux-install
 
-download: $(patsubst %,%-source,$(TARGETS-y))
+download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
 compile: linux-compile image_compile
 install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
@@ -32,8 +38,8 @@ image_install: image_compile
 
 %-clean: FORCE
        $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-source: FORCE
-       $(MAKE) -C $(patsubst %-source,%,$@) source
+%-download: FORCE
+       $(MAKE) -C $(patsubst %-download,%,$@) download
 %-prepare: FORCE
        $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
 %-compile: %-prepare