update ipsec-tools to 0.6.6, add a patch to build on 2.6.19, use Configure template
[openwrt.git] / rules.mk
index d52539f..a593468 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -58,6 +58,10 @@ PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR)/bin/sed -i -e
 CP:=cp -fpR
 
+INSTALL_BIN:=install -m0755
+INSTALL_DIR:=install -d -m0755
+INSTALL_DATA:=install -m0644
+
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
   export CCACHE_DIR=$(STAGING_DIR)/ccache