Make nls-base dependency 2.6 specific, really closes #1647
[openwrt.git] / package / zd1211 / Makefile
index ba7308c..b797c85 100644 (file)
@@ -1,32 +1,46 @@
-# $Id: Makefile 3297 2006-03-02 23:42:52Z florian $
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=zd1211
-PKG_VERSION:=r69
+PKG_VERSION:=r83
 PKG_RELEASE:=1
-PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
 PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
+PKG_MD5SUM:=a5751f0e6f1f368689077fa7758a4932
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 #FIXME: add proper dependency handling on kmod-usb-core packages
-define Package/kmod-zd1211
-SECTION:=drivers
-CATEGORY:=Drivers
-DEPENDS:=@LINUX_2_6
-TITLE:=Driver for Zydas 1211 based USB devices
-DESCRIPTION:=Driver for Zydas 1211 based USB devices \\\
-Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip.\\\
-Initially contributed by ZyDAS, this driver is actively maintained by the \\\
-open source community.
-URL:=http://zd1211.ath.cx/
-VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+define KernelPackage/zd1211
+  SUBMENU:=Wireless Drivers
+  DEPENDS:=@LINUX_2_6&&!LINUX_2_6_UML
+  TITLE:=Driver for Zydas 1211 based USB devices
+  DESCRIPTION:=\
+       This package contains a Linux driver for the ZyDAS ZD1211 802.11b/g \\\
+       USB-WLAN-Chip.\\\
+       Initially contributed by ZyDAS, this driver is actively maintained by the \\\
+       open source community.
+  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  FILES:=$(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,zd1211) 
+endef
+
+define Package/zd1211-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=zd1211 user-space utilities
+  DESCRIPTION:=zd1211 user-space utilities : apdbg, zd1211-sta
 endef
 
 define Build/Compile
@@ -36,7 +50,6 @@ define Build/Compile
                CC="$(TARGET_CC)" \
                CPP="$(TARGET_CC)" \
                LD="$(TARGET_CROSS)ld" \
-               STAGING_DIR=$(STAGING_DIR) \
                KERNELVERSION="$(KERNEL)" \
                KERNEL_SOURCE="$(LINUX_DIR)" \
                KDIR="$(LINUX_DIR)" \
@@ -44,13 +57,11 @@ define Build/Compile
        $(TARGET_CC) $(PKG_BUILD_DIR)/apdbg.c -o $(PKG_BUILD_DIR)/apdbg
 endef
 
-define Package/kmod-zd1211/install
-       install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
-       $(CP) $(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX) \
-               $(1)/lib/modules/$(LINUX_VERSION)/
-       install -m0755 -d $(1)/usr/sbin
+define Package/zd1211-utils/install
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/apdbg $(1)/usr/sbin/
        $(CP) $(PKG_BUILD_DIR)/sta $(1)/usr/sbin/$(PKG_NAME)-sta
 endef
 
-$(eval $(call BuildPackage,kmod-zd1211))
+$(eval $(call Package,zd1211-utils))
+$(eval $(call KernelPackage,zd1211))