acx-mac80211: fix compilation
[openwrt.git] / package / udev / Makefile
index f14fb3b..7673be7 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udev
-PKG_VERSION:=142
+PKG_VERSION:=173
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/hotplug/
-PKG_MD5SUM:=3edc4cf383dccb06d866c5156d59ddd5
+PKG_MD5SUM:=91a88a359b60bbd074b024883cc0dbde
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,10 +22,11 @@ PKG_INSTALL=1
 define Package/udev
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=@LINUX_2_6
   TITLE:=Dynamic device management subsystem
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
   MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+  MENU:=1
+  DEPENDS:=+librt
 endef
 
 define Package/udev/description
@@ -33,16 +34,29 @@ define Package/udev/description
        provides the ability to have persistent device names.
 endef
 
+define Package/udev/conffiles
+/etc/udev/udev.conf
+endef
+
 define Package/udev/config
-       source "$(SOURCE)/udev-config.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 udev-args-$(CONFIG_UDEV_DISABLE_LOGGING) += --disable-logging
 udev-args-$(CONFIG_UDEV_ENABLE_DEBUG) += --enable-debug
+udev-args-$(CONFIG_UDEV_EXTRA_edd_id) += --enable-edd
+udev-args-$(CONFIG_UDEV_EXTRA_floppy) += --enable-floppy
+
+# TODO: make hwdb and introspection work
 
 CONFIGURE_ARGS += --prefix=/usr --exec-prefix= --sysconfdir=/etc \
+       --disable-hwdb --disable-keymap --disable-gudev --disable-introspection \
+       --libexecdir=/lib/udev --disable-gtk-doc-html \
        --sbindir=/sbin $(udev-args-y)
 
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_accelerometer) += accelerometer
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_accelerometer) += 61-accelerometer.rules
+
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_ata_id) += ata_id
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_cdrom_id) += cdrom_id
@@ -53,16 +67,24 @@ udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_collect) += collect
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_edd_id) += edd_id
 udev-extra-rules-$(CONFIG_UDEV_EXTRA_edd_id) += 61-persistent-storage-edd.rules
 
-udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_firmware) += firmware.sh
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_firmware) += firmware
 udev-extra-rules-$(CONFIG_UDEV_EXTRA_firmware) += 50-firmware.rules
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_floppy) += create_floppy_devices
 
-udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_fstab_import) += fstab_import
-udev-extra-rules-$(CONFIG_UDEV_EXTRA_fstab_import) += 79-fstab_import.rules
+# TODO: make gudev work
+
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_input_id) += input_id
+
+# TODO: make keymap work
+
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_mtd_probe) += mtd_probe
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_mtd_probe) += 75-probe_mtd.rules
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_path_id) += path_id
 
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_qemu) += 42-qemu-usb.rules
+
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_rule_generator) += \
        write_cd_rules write_net_rules
 udev-extra-lib-data-$(CONFIG_UDEV_EXTRA_rule_generator) += \
@@ -72,8 +94,24 @@ udev-extra-rules-$(CONFIG_UDEV_EXTRA_rule_generator) += \
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_scsi_id) += scsi_id
 
+# TODO: make udev-acl work
+
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_usb_id) += usb_id
 
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_v4l_id) += v4l_id
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_v4l_id) += 60-persistent-v4l.rules
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libudev.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/share/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/pkgconfig/udev.pc $(1)/usr/share/pkgconfig
+       $(INSTALL_DIR) $(1)/lib
+       $(CP) $(PKG_INSTALL_DIR)/lib/libudev.so* $(1)/lib
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/lib/pkgconfig/libudev.pc $(1)/usr/lib/pkgconfig
+endef
+
 define Package/udev/install
        $(INSTALL_DIR) $(1)/etc/udev/rules.d
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/udev/udev.conf $(1)/etc/udev
@@ -98,9 +136,7 @@ define Package/udev/install
                $(1)/lib/udev/rules.d
 
        $(INSTALL_DIR) $(1)/lib
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/lib/libudev.so.* \
-               $(1)/lib
+       $(CP) $(PKG_INSTALL_DIR)/lib/libudev.so* $(1)/lib
 
        $(INSTALL_DIR) $(1)/lib/udev
 ifneq ($(udev-extra-lib-bin-y),)