uci: increase argv size in batch mode to silence a false gcc 4.4 compiler warning
[openwrt.git] / package / uci / Makefile
index 4b77baa..b88e72c 100644 (file)
@@ -4,12 +4,11 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=0.4
-UCI_RELEASE=1
+UCI_VERSION=0.7
+UCI_RELEASE=5
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
@@ -17,7 +16,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=381b5da987b206b3ab5d666785fbb833
+PKG_MD5SUM:=ed34c5ef606a90da4aba03ce6d22eeb9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,13 +36,6 @@ define Package/uci
   TITLE:=Utility for the Unified Configuration Interface (UCI)
 endef
 
-define Package/uci-sh
-  SECTION:=base
-  CATEGORY:=Base system
-  DEPENDS:=@!PACKAGE_uci
-  TITLE:=Old shell/awk implementation of UCI
-endef
-
 define Package/libuci-lua
   SECTION=libs
   CATEGORY=Libraries
@@ -54,14 +46,20 @@ endef
 define Build/Configure
 endef
 
+TARGET_CFLAGS += $(FPIC)
 UCI_MAKEOPTS = \
                $(TARGET_CONFIGURE_OPTS) \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
                VERSION="$(UCI_VERSION)" \
-               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+               CPPFLAGS="-I$(PKG_BUILD_DIR) $(TARGET_CPPFLAGS)" \
                OS="Linux"
 
+# work around a nasty gcc bug
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
+  UCI_MAKEOPTS += WOPTS=""
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
        $(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)
@@ -78,14 +76,10 @@ define Package/libuci-lua/install
 endef
 
 define Package/uci/install
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uci $(1)/sbin/
-       $(CP) ./files/uci/* $(1)/
-endef
-
-define Package/uci-sh/install
-       $(INSTALL_DIR) $(1)
-       $(CP) ./files/uci-sh/* $(1)/
+       $(CP) ./files/* $(1)/
 endef
 
 define Build/InstallDev
@@ -93,9 +87,10 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuci.a $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libucimap.a $(1)/usr/lib
 endef
 
 $(eval $(call BuildPackage,uci))
 $(eval $(call BuildPackage,libuci))
 $(eval $(call BuildPackage,libuci-lua))
-$(eval $(call BuildPackage,uci-sh))